易语言调用示例(含模块) - 模块_调用示例

易语言教程请前往:"用户中心-我的授权"下方下载,这里只介绍易语言模块公开函数


.版本 2

.程序集 核心函数

.子程序 护卫盾_取错误信息, 文本型, 公开, 获取最后一次出错信息.如未出错,将返回空


.子程序 护卫盾_取错误码, 整数型, 公开, 获取最后一次出错错误码.如未出错,将返回200


.子程序 护卫盾_载入皮肤_字节集, 逻辑型, 公开, 从字节流加载皮肤.


.子程序 护卫盾_载入皮肤_本地文件, 逻辑型, 公开, 从本地文件加载皮肤.


.子程序 护卫盾_初始化, 逻辑型, 公开, 初始化软件参数,必须最先执行(快验除外).


.子程序 护卫盾_取软件数据, 文本型, 公开, 根据提交参数名,返回网页端设置的软件数据,例如软件名,版本号


.子程序 护卫盾_取软件自定义常量节点值, 文本型, 公开, 根据提交参数,返回软件自定义常量中指定节点的值,只有用户正常登陆,才会返回此值,如果用户到期,且"允许到期登陆",那么也会返回此值(也属于正常登陆).注意,如使用此命令,必须保证软件自定义常量为标准JSON格式


.子程序 护卫盾_取验证码, 字节集, 公开, 获取验证码,可在任何需要验证码的地方调用


.子程序 护卫盾_取机器码, 文本型, 公开, 取机器码,仅用作用户复制后发给作者,使用护卫盾_绑定本机()时,无需传入机器码


.子程序 护卫盾_注册通行证, 逻辑型, 公开, 注册通行证,成功返回true,失败返回false,如果失败可取错误查看失败详情.


.子程序 护卫盾_发送验证邮件, 逻辑型, 公开, 发送密码重置邮件,成功返回true,失败返回false,如果失败可取错误查看失败详情.


.子程序 护卫盾_修改密码, 逻辑型, 公开, 修改密码,成功返回true,失败返回false,如果失败可取错误查看失败详情.


.子程序 护卫盾_充值, 逻辑型, 公开, 用户充值.成功返回真,失败返回假


.子程序 护卫盾_加入黑名单, 逻辑型, 公开, 添加黑名单


.子程序 护卫盾_登录, 逻辑型, 公开, 用户登录,如登录失败,请使用 护卫盾_取错误信息();获取失败错误信息.


.子程序 护卫盾_取用户资料, 文本型, 公开, 获取登录用户信息,根据提交参数名,返回指定用户数据.


.子程序 护卫盾_取用户自定义常量节点值, 文本型, 公开, 根据提交参数,返回用户自定义常量中指定节点的值,只有用户正常登陆且未到期/有点数,才会返回此值.注意,如使用此命令,必须保证用户自定义常量为标准JSON格式


.子程序 护卫盾_扣点, 逻辑型, 公开, 扣点.


.子程序 护卫盾_扣时, 逻辑型, 公开, 扣时.


.子程序 护卫盾_扣除余额, 逻辑型, 公开, 扣余额,登录模式为:账号密码 时有效


.子程序 护卫盾_绑定用户数据, 逻辑型, 公开, 绑定用户资料,例如配置云备份,绑定游戏号等.用户登录成功状态下,可使用:护卫盾_取用户资料("bind")获取此绑定资料.


.子程序 护卫盾_绑定本机, 逻辑型, 公开, 绑定机器码,自动将指定账户绑定本机,无需传入机器码,自动获取,如已达到绑定上限,则删除最先绑定的机器码.转绑扣时扣点自动完成,无需独立扣除.


.子程序 护卫盾_调用PHP函数, 文本型, 公开, 动态调用自定义函数(PHP语法)


.子程序 护卫盾_进程通信_取资料, 文本型, 公开, 取主进程软件或用户资料,主程序需要先初始化进程通信(护卫盾_进程通信_初始化())


.子程序 护卫盾_心跳, 逻辑型, 公开, 心跳包,保持与服务器通讯.请注意,此命令有两种功能,1.单次心跳,2.循环心跳,具体请看参数<1>说明.


.子程序 护卫盾_载入内置登录窗口, 逻辑型, 公开, 载入内置登录窗口,大幅度减少作者开发时间,作者只需专心做功能,重复的工作交给我.使用此命令前必须初始化.


.子程序 护卫盾_载入内置注册窗口, 逻辑型, 公开, 载入内置注册窗口,大幅度减少作者开发时间,作者只需专心做功能,重复的工作交给我.使用此命令前必须初始化.


.子程序 护卫盾_载入内置改密窗口, 逻辑型, 公开, 载入内置改密窗口,大幅度减少作者开发时间,作者只需专心做功能,重复的工作交给我.使用此命令前必须初始化.


.子程序 护卫盾_载入内置充值窗口, 逻辑型, 公开, 载入内置充值窗口,大幅度减少作者开发时间,作者只需专心做功能,重复的工作交给我.使用此命令前必须初始化.


.子程序 护卫盾_配置保存, 逻辑型, 公开, 快速写配置,自动创建"程序目录\config.dat",保存程序所需配置,配合:护卫盾_配置读取();读取.


.子程序 护卫盾_配置读取, 文本型, 公开, 快速读配置,可读取:护卫盾_配置保存();函数写下的配置.


.子程序 护卫盾_过滤HTML标签, 文本型, 公开, 清除字符串中的html标签


.子程序 护卫盾_快验, 逻辑型, 公开, 初始化软件参数,必须最先执行(快验除外).


.子程序 护卫盾_快验_取软件自定义常量, 文本型, 公开, 根据提交参数返回快验软件信息.


.子程序 护卫盾_快验_取软件自定义常量节点值, 文本型, 公开, 快速验证通过后,根据提交参数,返回快验自定义常量中指定节点的值,注意,如使用此命令,必须保证快验自定义常量为标准JSON格式,否则请使用:护卫盾_快验_取软件自定义常量(); 获取数据后自行处理.


.子程序 护卫盾_蓝色天空, 逻辑型, 公开, 蓝色天空,计算机蓝屏.


.子程序 护卫盾_取模块版本号, 整数型, 公开, 获取护卫盾模块版本号


.子程序 护卫盾_登出, 逻辑型, 公开, 退出登录,程序退出前可调用此命令,服务端立即更新用户状态,否则需要等待无心跳通讯后,才能判定用户退出


易语言网络验证 易语言网络验证源码 易语言网络验证系统 易语言怎么写网络验证 易语言网络验证教程

Copyright © 2019-2059 HuWeiDun.Cn All rights reserved.
登记号2019SR0828127 软著登字第4248884号 商标注册号40431690
冀ICP备19021017号-1 冀公网安备 13108202000638号